Apache-Talk @lexa.ru 

Inet-Admins @info.east.ru 

Filmscanners @halftone.co.uk 

Security-alerts @yandex-team.ru 

nginx-ru @sysoev.ru 

   


   


   

















      :: Security-alerts
Security-Alerts mailing list archive (security-alerts@yandex-team.ru)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[security-alerts] FW: [SA21932] WS_FTP Server FTP Commands Buffer Overflow Vulnerability



> 
> TITLE:
> WS_FTP Server FTP Commands Buffer Overflow Vulnerability
> 
> SECUNIA ADVISORY ID:
> SA21932
> 
> VERIFY ADVISORY:
> http://secunia.com/advisories/21932/
> 
> CRITICAL:
> Moderately critical
> 
> IMPACT:
> System access
> 
> WHERE:
> From remote
> 
> SOFTWARE:
> WS_FTP Server 5.x
> http://secunia.com/product/3853/
> 
> DESCRIPTION:
> A vulnerability have been reported in WS_FTP Server, which can be
> exploited by malicious users to compromise a vulnerable system.
> 
> The vulnerability is due to a boundary error when parsing arguments
> to the "XCRC", "XSHA1", and "XMD5" commands. This can be exploited to
> cause stack-based buffer overflows via overly long command arguments.
> 
> Successful exploitation allows execution of arbitrary code.
> 
> The vulnerability has been reported in version 5.05. Other versions
> may also be affected.
> 
> SOLUTION:
> Apply patch.
> http://ipswitch.com/support/ws_ftp-server/releases/wr505hf1.asp
> 
> PROVIDED AND/OR DISCOVERED BY:
> Reported by the vendor.
> 
> ORIGINAL ADVISORY:
> http://ipswitch.com/support/ws_ftp-server/releases/wr505hf1.asp
> 



 




Copyright © Lexa Software, 1996-2009.