Apache-Talk @lexa.ru 

Inet-Admins @info.east.ru 

Filmscanners @halftone.co.uk 

Security-alerts @yandex-team.ru 

nginx-ru @sysoev.ru 

   


   


   

















      :: Security-alerts
Security-Alerts mailing list archive (security-alerts@yandex-team.ru)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[security-alerts] FW: [SA26744] Quagga Multiple Denial of Service Vulnerabilities



>
> TITLE:
> Quagga Multiple Denial of Service Vulnerabilities
>
> SECUNIA ADVISORY ID:
> SA26744
>
> VERIFY ADVISORY:
> http://secunia.com/advisories/26744/
>
> CRITICAL:
> Less critical
>
> IMPACT:
> DoS
>
> WHERE:
> From remote
>
> SOFTWARE:
> Quagga 0.x
> http://secunia.com/product/4731/
>
> DESCRIPTION:
> Some vulnerabilities have been reported in Quagga, which can be
> exploited by malicious users to cause a DoS (Denial of Service).
>
> The vulnerabilities are caused due to bgpd improperly handling
> messages and attributes sent by peers. This can be exploited to crash
> bgpd by sending a specially crafted "OPEN" message or a specially
> crafted "COMMUNITY" attribute to the affected server.
>
> Successful exploitation requires that the attacker is configured as
> peer of the victim system, and that the debugging of BGP updates is
> on.
>
> The vulnerabilities are reported in versions prior to 0.99.9.
>
> SOLUTION:
> Fixed in unstable version 0.99.9.
>
> Connect to trusted peers only.
>
> PROVIDED AND/OR DISCOVERED BY:
> The vendor credits Mu Security.
>
> ORIGINAL ADVISORY:
> http://www.quagga.net/download/quagga-0.99.9.changelog.txt
>



 




Copyright © Lexa Software, 1996-2009.