Apache-Talk @lexa.ru 

Inet-Admins @info.east.ru 

Filmscanners @halftone.co.uk 

Security-alerts @yandex-team.ru 

nginx-ru @sysoev.ru 

   


   


   

















      :: Security-alerts
Security-Alerts mailing list archive (security-alerts@yandex-team.ru)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[security-alerts] FW: [SA24808] Quagga "reachable/unreachable" NLRI Attributes Denial of Service



> ----------------------------------------------------------------------
> 
> TITLE:
> Quagga "reachable/unreachable" NLRI Attributes Denial of Service
> 
> SECUNIA ADVISORY ID:
> SA24808
> 
> VERIFY ADVISORY:
> http://secunia.com/advisories/24808/
> 
> CRITICAL:
> Less critical
> 
> IMPACT:
> DoS
> 
> WHERE:
> From remote
> 
> SOFTWARE:
> Quagga 0.x
> http://secunia.com/product/4731/
> 
> DESCRIPTION:
> Paul Jakma has reported a vulnerability in Quagga, which can be
> exploited by malicious users to cause a DoS (Denial of Service).
> 
> The vulnerability is caused due to bgpd not checking the length
> information of the "MP_UNREACH_NLRI" and  "MP_REACH_NLRI" attributes.
> This can be exploited to cause an assertion error or out of bounds
> read by sending a specially crafted UPDATE message.
> 
> Successful exploitation requires that the attacker is configured as
> peer of the victim system.
> 
> The vulnerability is reported in all existing Quagga versions.
> 
> SOLUTION:
> Connect to trusted peers only.
> 
> PROVIDED AND/OR DISCOVERED BY:
> Paul Jakma
> 
> ORIGINAL ADVISORY:
> http://www.quagga.net/news2.php?y=2007&m=4&d=8#id1176073740
> http://bugzilla.quagga.net/show_bug.cgi?id=354
> 



 




Copyright © Lexa Software, 1996-2009.